Minimum System Requirements

In this article
GEVME is a cloud-based application which works in most modern web browsers. Hence, the only things that you need are a compatible browser and an internet connection. There is no need to download or install any software to your computer (apart from the browser of course).
Before we go through the list of compatible browsers and required browser settings, it is necessary to explain the concepts of backend and front-end. GEVME is quite a big application with different portions of it meant for different types of users and on the overall, the various endpoints can be categorised under either the backend of the application or the front-end of the application.
The Backend
Any part of the software which is meant to be accessed by you, the registered user of GEVME (i.e. the one organizing or managing the event), is considered to be the backend. For example, when you login to GEVME and manage an event, that’s the backend:
The backend is never meant to be accessed by the participants and always requires authentication, i.e. you have to login using your GEVME username and password in order to access it.
The Front-end

All parts of the application which are meant to be accessed by the participant is considered to be the front-end of GEVME. For example, the Event Page and the registration page are all considered to be front-end.


Most front-end parts of GEVME do not require authentication in order to be accessed. However, there are exceptions, e.g. the GEVME Wallet app which is front-end but which requires the participant to login in order to be accessed.

Compatible browsers for the Backend
  1. Google Chrome
  2. Mozilla Firefox
  3. Safari on the mac
  4. Microsoft Internet Explorer (Version 9 and above)

Mobile compatibility

The backend is not optimised to be used on mobile devices, but most features would be accessible and usable on tablets.

Compatible browsers for the Front-End
  1. Google Chrome
  2. Mozilla Firefox
  3. Safari on the mac
  4. Microsoft Internet Explorer (Version 8 and above)

Mobile compatibility

All parts of the front-end are mobile compatible and responsive.

Browser Settings

In order for GEVME (both the backend and front-end) to work as expected, the following browser settings are required:

  1. Cookies must be enabled
    To enable cookies on your respective browser, the following links can be helpful:
  2. JavaScript must be enabled
    By default, JavaScript is enabled in all modern browsers (the latest Firefox versions don't even allow it to be turned off). However, if you are having doubts about whether it's enabled or not in your browser, this link can be helpful.
  3. Minimum screen resolution of 1024 x 768
    For optimal viewing of the backend, a minimum resolution of 1024 x 768 is required.
    For the front-end, any resolution will work fine as all front-end parts of GEVME are responsive.